WP Super Cache mod_expires模块丢失

Posted by Harid五月 - 19 - 2011 Leave comments

LNMP搭建的Web环境,在装好Wp super cache后可能会出现下列错误:

Apache 模块丢失
mod_expires – 需要在supercache页面设置缓存讯息。没有这个模块,访客在刷新或留言时可能看不到新页面。

从军哥那了解到,该模块已经存在了,只需要安装上即可。

首先找出“ mod_expires.c”文件的位置,执行:

1
locate mod_expires.c

然后再执行:

1
/usr/local/apache/bin/apxs -i -a -c mod_expires.c的路径

如我执行的是:

1
/usr/local/apache/bin/apxs -i -a -c /usr/local/src/httpd-2.2.17/modules/metadata/mod_expires.c

20110519_008

最后重启httpd服务:

1
service httpd restart

   声明:本文采用 BY-NC-SA 协议进行授权 | 星期九
   原创文章转载请注明:转自《WP Super Cache mod_expires模块丢失

    • @yesureadmin, 🙂 ,不是,昨天上午是因为httpd僵死,然后我换了个机房,换机房后我就没有管了,去打球去了。所以一直到晚上才好。谢谢关注啊,以后不这么不在意了!

  1. 现在不用这个插件,容易导致别的问题出现,不过还是学习了。


分享按钮